require PHP == 5.2 !